Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005459OCamlOCaml generalpublic2012-01-02 20:092013-08-31 12:44
ReporterChristophe Troestler 
Assigned Tolefessan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionsuspended 
Platformx86_64OSDebian GNU/LinuxOS Version3.10.0
Product Version3.12.1 
Target VersionFixed in Version 
Summary0005459: ocamlc -o not respected for C files
DescriptionWhen compiling a C file with ocamlc, the -o flag can be set but is not used. It is occasionally useful however, for example when different objects files may be produced by defining some macros.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006710)
lefessan (developer)
2012-01-17 23:21

It looks like there are still some C compilers that don't comply to the -o option. If we don't use the C compiler -o option, ocamlc has to rename the object file itself, but then, it might clash with parallel compilation.

 For these reasons, this feature is "suspended" until all known C compilers implement the -o option correctly.

Note that it is still possible to use -o with C files using the -ccopt option, if you don't care too much about portability across C compilers.

- Issue History
Date Modified Username Field Change
2012-01-02 20:09 Christophe Troestler New Issue
2012-01-17 23:21 lefessan Note Added: 0006710
2012-01-17 23:21 lefessan Status new => resolved
2012-01-17 23:21 lefessan Resolution open => suspended
2012-01-17 23:21 lefessan Assigned To => lefessan
2013-08-31 12:44 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker