Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005464OCamlOCaml documentationpublic2012-01-04 15:582013-08-31 12:44
Reportermehdi 
Assigned Tolefessan 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.12.1 
Target VersionFixed in Version3.13.0+dev 
Summary0005464: Missing @dircategory and @direntry to info files
DescriptionThere is one problem in the info file
    usr/share/info/ocaml.info.gz
because it does not ship info dir sections. Thus, calling install-info (the GNU version) on these files issue a warning:
    install-info: warning: no info dir entry in `/usr/share/info/...'
and the file is not included in the dir file.

The source of this problem is the following missing entry in the
texinfo source:
    @dircategory Package short info
    @direntry
    * menu item 1: (infofile). Description.
    * menu item 2: (infofile2). Description.
    @end direntry
Additional InformationAdditional information can be found in:
  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=528887 [^]
  http://lintian.debian.org/tags/info-document-missing-dir-entry.html [^]
  http://lintian.debian.org/tags/info-document-missing-dir-section.html [^]
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006602)
lefessan (developer)
2012-01-05 22:43

From what I understand, since OCaml Manual is generated by Hevea, the bug should be sent to Hevea's maintainers. In the meantime, the OCaml manual could be fixed by adding (manually, in the Makefile) something like this to ocaml.info (after the first line):

INFO-DIR-SECTION OCaml Programming Language
START-INFO-DIR-ENTRY
* ocaml: (ocaml). OCaml Reference Manual
END-INFO-DIR-ENTRY
(0006606)
lefessan (developer)
2012-01-06 08:56

I submitted a fix in the ocamldoc SVN, commit r11993. If nobody complains about it, I will close this bug report.
(0006632)
mehdi (reporter)
2012-01-09 14:37

Thanks!

- Issue History
Date Modified Username Field Change
2012-01-04 15:58 mehdi New Issue
2012-01-05 22:43 lefessan Note Added: 0006602
2012-01-06 08:56 lefessan Note Added: 0006606
2012-01-09 14:37 mehdi Note Added: 0006632
2012-01-10 09:47 lefessan Status new => resolved
2012-01-10 09:47 lefessan Fixed in Version => 3.13.0+dev
2012-01-10 09:47 lefessan Resolution open => fixed
2012-01-10 09:47 lefessan Assigned To => lefessan
2013-08-31 12:44 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker