Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005483OCamlOCaml generalpublic2012-01-18 16:502013-05-17 21:33
Reporterglondu 
Assigned Toxclerc 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionduplicate 
PlatformOSOS Version
Product Version3.13.0+dev 
Target Version4.00.1+devFixed in Version4.01.0+dev 
Summary0005483: The testsuite cannot be run without installation
DescriptionCurrently (r12043), the testsuite assumes that ocaml has been installed. For example, it calls $PREFIX/bin/ocamlc, or ./program where program is a bytecode executable refering to $PREFIX/bin/ocamlrun.

Moreover, the testsuite somehow assumes that the compilation tree is still around. For example, it uses config/Makefile.

I would like to run the testsuite automatically as part of the Debian release process, on all supported architectures, but these shortcomings prevents it without multiple compilations (not counting bootstrap): the only workaround I can think of is to compile everything one time with a local $PREFIX for running the tests, and then with a global $PREFIX for the released binaries.

I don't know the details of gcc and (e)glibc, but the test-suite of coq (at least) can be run without recompiling a throw-away version of everything.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0005710closeddoligez test suite cannot be ran without installing first 

-  Notes
(0007677)
doligez (administrator)
2012-07-10 11:42

We are now at r12681, and I think this has been fixed. Xavier?
(0007707)
frisch (developer)
2012-07-11 13:51

I've no idea whether this has been fixed or not, but since the test suite is not part of the distribution, I don't think this should be considering blocking for 4.00.
(0007710)
xclerc (developer)
2012-07-11 14:33

One still has to install in order to run the test suite.

It should be possible to change that by playing with -nopervasives,
LD_LIBRARY_PATH and the like, but it is worth the trouble?
(0007858)
protz (manager)
2012-08-01 11:12

Side-note: 0005710 has a patch for that!

- Issue History
Date Modified Username Field Change
2012-01-18 16:50 glondu New Issue
2012-01-18 16:57 xclerc Assigned To => xclerc
2012-01-18 16:57 xclerc Status new => assigned
2012-07-10 11:42 doligez Note Added: 0007677
2012-07-10 11:42 doligez Target Version => 4.00.0+dev
2012-07-11 13:51 frisch Note Added: 0007707
2012-07-11 14:33 xclerc Note Added: 0007710
2012-07-11 15:46 doligez Target Version 4.00.0+dev => 4.01.0+dev
2012-07-31 13:36 doligez Target Version 4.01.0+dev => 4.00.1+dev
2012-08-01 10:19 frisch Relationship added has duplicate 0005710
2012-08-01 11:12 protz Note Added: 0007858
2012-08-01 11:15 frisch Relationship replaced duplicate of 0005710
2012-08-01 11:15 frisch Status assigned => resolved
2012-08-01 11:15 frisch Resolution open => duplicate
2013-05-17 21:33 doligez Status resolved => closed
2013-05-17 21:33 doligez Fixed in Version => 4.01.0+dev


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker