Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005486OCamlOCaml documentationpublic2012-01-20 03:022013-08-31 12:44
Reporterblue_prawn 
Assigned Tofrisch 
PrioritynoneSeveritytrivialReproducibilityalways
StatusclosedResolutionno change required 
PlatformnoarchOSOS Version
Product Version3.12.1 
Target VersionFixed in Version 
Summary0005486: type Unix.tm.tm_sec documentation
Description  tm_sec : int; (* Seconds 0..60 *)

the range is in fact 0..59
TagsNo tags attached.
Attached Filespatch file icon unix_tm_sec_0_59.patch [^] (463 bytes) 2012-01-20 03:02 [Show Content]

- Relationships

-  Notes
(0006745)
frisch (developer)
2012-01-20 07:31

I think the doc is correct, because of leap seconds.

http://pubs.opengroup.org/onlinepubs/009695399/basedefs/time.h.html [^]

http://stackoverflow.com/questions/765778/why-does-tm-sec-range-from-0-60-instead-of-0-59-in-time-h [^]

- Issue History
Date Modified Username Field Change
2012-01-20 03:02 blue_prawn New Issue
2012-01-20 03:02 blue_prawn File Added: unix_tm_sec_0_59.patch
2012-01-20 07:31 frisch Note Added: 0006745
2012-01-20 07:31 frisch Status new => resolved
2012-01-20 07:31 frisch Resolution open => no change required
2012-01-20 07:31 frisch Assigned To => frisch
2013-08-31 12:44 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker