Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005490OCamlOCaml generalpublic2012-01-20 15:022013-08-31 12:46
Reporterdim 
Assigned Tofrisch 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version3.13.0+dev 
Target VersionFixed in Version 
Summary0005490: Unbound variable after pattern with gadt
DescriptionThe following code produce an error with trunk:

  type t = A : t

  let f () =
    let A = A in
    let x = 0 in
    x

File "toto.ml", line 4, characters 2-33:
Error: Unbound value x

I did a git bisect and the bug appears at commit 12050.
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0006759)
frisch (developer)
2012-01-20 15:26

Fixed in rev 12059.

The code was probably buggy before the commit you mention, because the analysis of free identifiers in Unused_var was incomplete (but now it is more incomplete, so the error was simpler to trigger).

- Issue History
Date Modified Username Field Change
2012-01-20 15:02 dim New Issue
2012-01-20 15:26 frisch Note Added: 0006759
2012-01-20 15:26 frisch Status new => resolved
2012-01-20 15:26 frisch Resolution open => fixed
2012-01-20 15:26 frisch Assigned To => frisch
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker