Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005505OCamlOCaml backend (code generation)public2012-02-14 17:222013-08-31 12:46
Reportercgillot 
Assigned Toprotz 
PrioritylowSeverityfeatureReproducibilityN/A
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005505: Debugging information in native code
DescriptionI've a c++ project using caml as extension language, calling (native) ocaml code via callbacks.
I would like to be able to debug both c++ and ocaml code in gdb, since the coupling between the languages is quite high.

Up to now, I've changed some asmcomp files in order to emit amd64 line informations.

Code based on the one found at :
http://blog.techno-barje.fr/post/2008/11/09/Ocaml-native-code-debugging/ [^]

The only meaningful code is in asmcomp/amd64/emit.mlp (the real symbols emission), and in bytecomp/translcore.ml (decorating lazy constructs).
The rest is transporting the information from one place to another.

Is it possible to have a more portable (and less hackish) version ?
TagsNo tags attached.
Attached Filespatch file icon native-debug-svn12153.patch [^] (17,990 bytes) 2012-02-14 17:22 [Show Content]

- Relationships
duplicate of 0005487closed Improved GDB support 

-  Notes
(0006919)
protz (manager)
2012-02-14 17:26

I believe what you want is discussed at length in another issue.

Thanks,

jonathan
(0006920)
cgillot (reporter)
2012-02-14 18:12

Thank you for redirecting me, I should have searched a bit longer.

Camille

- Issue History
Date Modified Username Field Change
2012-02-14 17:22 cgillot New Issue
2012-02-14 17:22 cgillot File Added: native-debug-svn12153.patch
2012-02-14 17:26 protz Note Added: 0006919
2012-02-14 17:26 protz Relationship added duplicate of 0005487
2012-02-14 17:26 protz Status new => resolved
2012-02-14 17:26 protz Resolution open => fixed
2012-02-14 17:26 protz Assigned To => protz
2012-02-14 18:12 cgillot Note Added: 0006920
2013-08-31 12:46 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker