Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005530OCamlOCaml tools (ocaml{lex,yacc,dep,browser,debug})public2012-03-09 13:422013-08-31 12:48
Reporterfrisch 
Assigned Tofrisch 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0005530: ocamldep does not show the filename in case of a syntax error
Descriptionocamldep reports syntax errors without a filename. (This is particularly painful when one uses a build system which computes dependencies automatically, like omake or ocamlbuild.)
TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0007030)
frisch (developer)
2012-03-09 13:45

Oops, sorry this has already been resolved on the trunk.
(0007031)
lefessan (developer)
2012-03-09 14:00

Do you understand why there is a need to both set Location.input_name and call Location.init everytime ? The problem was that Location.input_name was set, but Location.init was not called.

- Issue History
Date Modified Username Field Change
2012-03-09 13:42 frisch New Issue
2012-03-09 13:45 frisch Note Added: 0007030
2012-03-09 13:45 frisch Status new => resolved
2012-03-09 13:45 frisch Resolution open => fixed
2012-03-09 13:45 frisch Assigned To => frisch
2012-03-09 14:00 lefessan Note Added: 0007031
2013-08-19 15:58 doligez Category OCaml tools (ocaml{lex,yacc,dep,browser}) => OCaml tools (ocaml{lex,yacc,dep,browser,debug})
2013-08-31 12:48 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker