Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0005763OCamlOCamlbuild (the tool)public2012-09-21 15:462013-01-13 22:51
Reporterpveber 
Assigned Togasche 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformOSOS Version
Product Version4.00.0 
Target VersionFixed in Version 
Summary0005763: ocamlbuild does not give correct -I flags when running menhir
DescriptionThis bug is very similar to 0004572, this time it deals with the actual parser generation instead of the dependency discovery. In both cases menhir is passed an external command (either ocamldep or ocamlc) which should have the correct options. For the parser generation, the ocamlc command (passed through the --ocamlc switch) contains a '-I <directory of the mly source>' which is good in most frequent cases but is insufficient if the parser uses types that are defined in a third-party library. In my case it is a Camlp4 AST, and when I run ocamlbuild compilation it says 'Unbound module Camlp4'

There is a more thorough description of the problem and its current workaround on the caml-list:

https://sympa.inria.fr/sympa/arc/caml-list/2012-09/msg00083.html [^]
Additional InformationThe fix could be to change the function [menhir] in ocamlbuild/ocaml_tools.ml, in analogy with what is done in [menhir_modular], as the current workaround is based on [menhir_modular].

I can try to write a patch if it can help!
TagsNo tags attached.
Attached Filestxt file icon fix_PR5763_ocamlbuild_menhir.txt [^] (932 bytes) 2012-09-21 17:17 [Show Content]

- Relationships

-  Notes
(0008141)
gasche (developer)
2012-09-21 17:19

The attached fix is now included in the SVN trunk (but not in the next minor release branch, so you'll have to wait a bit for the fix to propagate downstream). I would be glad if you confirmed that the attached patch indeed solves your issue.

Thanks for the report.
(0008143)
pveber (reporter)
2012-09-22 12:16

I confirm the patch fixes the issue. Thanks Gabriel!
(0008576)
jpdeplaix (reporter)
2012-12-06 09:10

I had the same bug with -package.
Is this bug will be included in 4.00.2 ?
(0008721)
daweil (reporter)
2013-01-08 22:54

Same for me, when I tried to use use menhir with ocamlfind and ocamlbuild.

- Issue History
Date Modified Username Field Change
2012-09-21 15:46 pveber New Issue
2012-09-21 17:17 gasche File Added: fix_PR5763_ocamlbuild_menhir.txt
2012-09-21 17:19 gasche Note Added: 0008141
2012-09-21 17:19 gasche Status new => resolved
2012-09-21 17:19 gasche Resolution open => fixed
2012-09-21 17:19 gasche Assigned To => gasche
2012-09-22 12:16 pveber Note Added: 0008143
2012-12-06 09:10 jpdeplaix Note Added: 0008576
2013-01-08 22:54 daweil Note Added: 0008721


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker