Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006131OCamlOCaml backend (code generation)public2013-08-18 19:202013-08-19 19:16
Reporterjpmathew 
Assigned Tomeurer 
PrioritynormalSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
PlatformARM v7OSLinux Linaro OS Versionlinaro-alip 3.3
Product Version4.00.1 
Target VersionFixed in Version4.01.0+dev 
Summary0006131: Ref: ID 0005910 - same error at different location in code for haxe compile
DescriptionWhile compiling haxe from source on Cubieboard2 with ARM v7 cpu, I am getting Shift expression too large with lsl#32.
But this is at a different location than the earlier ocaml version.
Steps To Reproducecompiled ocaml 4.00.1 from source - this step went OK. Then compiled haxe from source using ocaml install.ml and it fails on the assembler code: camlasm19e52e.s


Additional InformationI am using ARM v7. Earlier report said it was fixed and checked on Raspberry Pi which uses a different processor.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0005910resolvedmeurer assembler complains of invalid code 

-  Notes
(0010189)
meurer (developer)
2013-08-19 08:19
edited on: 2013-08-19 19:14

The fix for 5910 is not in 4.00.1. Please use trunk or 4.01 branch.

(0010190)
jpmathew (reporter)
2013-08-19 08:52

Today compiled haxe without ocaml install.ml, using git source and Makefiles.
It compiled OK. So please drop this.

- Issue History
Date Modified Username Field Change
2013-08-18 19:20 jpmathew New Issue
2013-08-19 08:19 meurer Note Added: 0010189
2013-08-19 08:19 meurer Relationship added duplicate of 0005910
2013-08-19 08:19 meurer Status new => resolved
2013-08-19 08:19 meurer Resolution open => duplicate
2013-08-19 08:19 meurer Assigned To => meurer
2013-08-19 08:52 jpmathew Note Added: 0010190
2013-08-19 08:52 jpmathew Status resolved => feedback
2013-08-19 08:52 jpmathew Resolution duplicate => reopened
2013-08-19 19:14 doligez Note Edited: 0010189 View Revisions
2013-08-19 19:16 doligez Status feedback => resolved
2013-08-19 19:16 doligez Resolution reopened => fixed
2013-08-19 19:16 doligez Fixed in Version => 4.01.0+dev


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker