Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0006166OCamlOCamlbuild (the tool)public2013-09-09 03:272013-09-09 10:54
Reporterberenger 
Assigned Toxclerc 
PriorityhighSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformallOSallOS Versionall
Product Version4.00.1 
Target VersionFixed in Version 
Summary0006166: no -ocamldoc option in ocamlbuild
DescriptionWhile there are the following options:
---
      -ocamlc <command>
              Set the OCaml bytecode compiler

       -ocamlopt <command>
              Set the OCaml native compiler

       -ocamldep <command>
              Set the OCaml dependency tool

       -ocamlyacc <command>
              Set the ocamlyacc tool

       -ocamllex <command>
              Set the ocamllex tool

       -ocamlrun <command>
              Set the ocamlrun tool
---

I wanted to force ocamlbuild into using ocamldoc.opt
instead of ocamldoc.
I could not, since the option is not there.
I had to tweak findlib.conf instead.
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0005065closedxclerc ocamlbuild, option -ocamldoc is missing 

-  Notes
(0010327)
dbuenzli (reporter)
2013-09-09 10:33

You must use an old OCaml this was fixed in 3.12.1 see PR 0005065.
(0010328)
berenger (reporter)
2013-09-09 10:41

OK, it is the manpage of ocamlbuild I read that doesn't mention it.
But yes, ocamlbuild has the option.
man /home/berenger/.opam/4.00.1/man/man1/ocamlbuild.1
(0010329)
berenger (reporter)
2013-09-09 10:41

So, the manpage is outdated.
(0010330)
xclerc (developer)
2013-09-09 10:48

Daniel is right, this is already fixed.
(0010331)
xclerc (developer)
2013-09-09 10:54

The documentation issue is also fixed as of commit 14076 in trunk.

- Issue History
Date Modified Username Field Change
2013-09-09 03:27 berenger New Issue
2013-09-09 10:33 dbuenzli Note Added: 0010327
2013-09-09 10:41 berenger Note Added: 0010328
2013-09-09 10:41 berenger Note Added: 0010329
2013-09-09 10:47 xclerc Relationship added duplicate of 0005065
2013-09-09 10:48 xclerc Note Added: 0010330
2013-09-09 10:48 xclerc Status new => closed
2013-09-09 10:48 xclerc Assigned To => xclerc
2013-09-09 10:48 xclerc Resolution open => duplicate
2013-09-09 10:53 xclerc Status closed => feedback
2013-09-09 10:53 xclerc Resolution duplicate => reopened
2013-09-09 10:54 xclerc Note Added: 0010331
2013-09-09 10:54 xclerc Status feedback => closed
2013-09-09 10:54 xclerc Resolution reopened => fixed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker