Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000009OCamlOCaml generalpublic1999-12-20 11:222012-09-25 20:07
Reporteradministrator 
Assigned Toxclerc 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version3.11+dev 
Summary0000009: ocamldebug ignores # linenum "filename"
DescriptionFull_Name: Norman Ramsey
Version: 2.04
OS:
Submission from: estephe.inria.fr (128.93.11.95)
Submitted by: xleroy


I'm running ocamldebug on a file that is litted with directives like
# 176 "rsync.nw"
   
Unfortunately, the debugger does not direct emacs to source file rsync.nw,
but uses lines in rsync.ml (the actual source file). Am I correct in
thinking that this behavior represents a bug?

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000096)
administrator (administrator)
2002-11-05 17:22

Needs to be done at some point, but not trivial.

We're getting closer to the goal. -- Damien 2002-11-05
(0004998)
xclerc (developer)
2009-06-17 10:17

A tentative fix has been committed in branch 'release311'.
(0006562)
doligez (administrator)
2011-12-30 16:34
edited on: 2011-12-30 16:38

Release 3.11.2 is long past, and quick testing indicates that this is fixed. I'm closing this PR.


- Issue History
Date Modified Username Field Change
2005-11-18 10:13 administrator New Issue
2009-05-18 16:25 xleroy Status acknowledged => assigned
2009-05-18 16:25 xleroy Assigned To => xclerc
2009-06-17 10:17 xclerc Note Added: 0004998
2011-12-30 16:34 doligez Note Added: 0006562
2011-12-30 16:38 doligez Status assigned => resolved
2011-12-30 16:38 doligez Fixed in Version => 3.11+dev
2011-12-30 16:38 doligez Resolution open => fixed
2011-12-30 16:38 doligez Note Edited: 0006562 View Revisions
2012-09-25 20:07 xleroy Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker