Version française
Home     About     Download     Resources     Contact us    
Browse thread
questions
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jacques GARRIGUE <garrigue@k...>
Subject: Re: questions
From: "Nickolay B. Semyonov" <snob@snob.spb.ru>

> I have few questions:
> 
> 1) Does anybody update Emacs-scripts in distribution of Ocaml to support
> Emacs 20.* ?

I do. If you have any problems you should send me a bug report, and I
will see what I can do.
The emacs scripts in the ocaml distribution should work with Emacs 20,
but the indentation code was not updated in ocaml-2.00. You should get
ocaml-mode-2.00.tar.gz from either http://pauillac.inria.fr/olabl/ or
http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/.

> 2) Is there any ocaml interface to OpenGL libraries?

Not for ocaml, but for olabl which is an extension of ocaml.
Ocaml's type system is too restrictive to provide such an interface in
a type safe way.
You can get more information from
	http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/

> 3) Is there any database support for Ocaml? SQL-interface or smth like it.

This is lower level but the ocaml distribution contains both a Dbm and
a Berkeley DB interface. I don't know about any SQL interface.

Regards,

	Jacques
---------------------------------------------------------------------------
Jacques Garrigue      Kyoto University     garrigue at kurims.kyoto-u.ac.jp
		<A HREF=http://wwwfun.kurims.kyoto-u.ac.jp/~garrigue/>JG</A>