Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] OCaml as fancy calculator...
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sven <luther@d...>
Subject: Re: [Caml-list] Re: ledit (was: OCaml as fancy calculator...)
On Thu, Aug 09, 2001 at 09:21:41AM +0200, Florian Hars wrote:
> On Tue, Aug 07, 2001 at 07:34:18PM +0200, Daniel de Rauglaudre wrote:
> > You need OCaml and Camlp4 versions 3.02 to compile the latest versions
> > of ledit.
> 
> This is bad, since it means that ledit will not be usable on Debian systems
> for at least the next two years. (Apart from the license problem that
> prohibits its inclusion anyway).

No, that is not true, i have uploaded a ocaml 3.02 to unstable, and i hope the 
camlp4 maintainer will do so also soon (if not, just submit a bug report against
it, and if that don't help, i will do a NMU of it).

lftp ftp.fr.debian.org:/debian/pool/main/o/ocaml> ls -l ocaml_3.02*
-rw-rw-r--   1 mysql    102          9745 Aug  3 17:33 ocaml_3.02-1.diff.gz
-rw-rw-r--   1 mysql    102           684 Aug  3 17:33 ocaml_3.02-1.dsc
-rw-rw-r--   1 mysql    102       4311250 Aug  4 03:15 ocaml_3.02-1_alpha.deb
-rw-rw-r--   1 mysql    102       2123598 Aug  4 02:06 ocaml_3.02-1_hppa.deb
-rw-rw-r--   1 mysql    102       3776464 Aug  3 17:33 ocaml_3.02-1_i386.deb
-rw-rw-r--   1 mysql    102       1614709 Aug  3 17:33 ocaml_3.02.orig.tar.gz

I have also planned to package ledit, but a disk crash came in the way, and was
rather busy since then. I don't think the licence problem is unsolvable, if there
is any (don't remember, will check again).

That said, debian has not yet freezed the boot floppies nor the policy, and
until the policy is not finalized, there cannot be a package freeze. Next will come,
if i am right, the base and essential package freeze, and planned for begin of
september the package freeze. But since the boot floppy freeze had some delay, the
package freeze will more probably be around october, in anyway this is far enough
time for an update to all the ocaml stuff.

Friendly,

Sven Luther
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr