Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[Caml-list] function vs. parser
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Daniel de Rauglaudre <daniel.de_rauglaudre@i...>
Subject: Re: [Caml-list] function vs. parser

> I have a petty complaint. Another name would have been better, say "parse"
> to match "match"

But "parser" is like "function", not like "match".

> since "parser" is a good name for a type and at least in English
> there are no good synonyms. If you start writing combinator parsers
> you have to hack the keyword parser to be parser_t or _parser or
> somesuch, which is a little ugly.

Same problem with "type": in my parsers, I would like to have "expr",
"patt" and "type". I named it "ctyp", ugly too. And "constraint"...
which is named "constrain" in the OCaml parser. It has been the
problem with keywords since the Pascal language...

> Hey, I said it is a *petty* complaint! ;-)

Well, there is some syntactic preprocessor for OCaml - I don't
remember the name - which can do that...

Bug reports:  FAQ:
To unsubscribe, mail  Archives: