Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] Test release Objective Caml 3.03 Alpha
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Christophe TROESTLER <debian00@t...>
Subject: Re: [Caml-list] Test release Objective Caml 3.03 Alpha
On Fri, 12 Oct 2001, Xavier Leroy <xavier.leroy@inria.fr> wrote:
> 
> An alpha release of what should eventually be Objective Caml 3.03 [...]

I just tried the alpha release out of curiosity [it compiles without
problem on my Debian Linux x86 box BTW] and used it on some of my
code.  That triggered the following questions.

> Q2: I get a syntax error when I try to compile a program using stream
>     parsers.
> 
> A2: Stream parser now require camlp4. It is included in the
>     distribution, and you just need to use "ocamlc -pp camlp4o" in
>     place of "ocamlc".

* Does the above means it is not possible anymore to use "parser"
  under the interactive system?

* Since camlp4 does not support the Bigarray notation (.{...}), does
  that imply that programs using parsers must not use it (or
  then--when possible--be divided into several sources that are
  compiled separately)?

ChriS


P.S.  I am in the process of learning OCaml, so please excuse if the
above questions have obvious answers.
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr