Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] Building O'Caml projects properly.
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Hideo Bannai <bannai@i...>
Subject: Re: [Caml-list] Building O'Caml projects properly.

Hello,

> On Mon, 01 Oct 2001, Jeremy Fincher wrote:
> > When I do a simple "gmake", it compiles all the files, and the directory
> > becomes filled with ".cmo" and ".cmx" files and so on.  After doing
> > a "make libinstall" and answering 'y' to the question it asks about
> > installation, the only things that remain in the directory are the
> > .ml files and the Makefile itself.  Somehow, given that Makefile,
> > it's removing all the files it installs.
> 
> I have never seen this happen and I really can't imagine how this could
> work. Could you please send me your Makefile? Maybe you have accidently
> added a dependency on the "clean"-target or similar.

Actually, it might be the difference in default behavior of the
`install' command. On my MacOS X, it moves the files by default,
where on my Linux box, they get copied.

Adding `-c' option to the install command in OcamlMakefile would do
the trick I think.

--
Hideo Bannai
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr