Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] Segv while compiling ocaml-3.04
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Xavier Leroy <xavier.leroy@i...>
Subject: Re: [Caml-list] Segv while compiling ocaml-3.04
> > As to which versions of gcc are affected: gcc 2.96 from RH 7.2 and
> > Mandrake 8.1 are,
> 
> I've not been able to reproduce under 8.1 
> (taking your srpm and removing the patch)

You need to look at the assembly code generated for the MD5Transform
function.  More explanations on the gcc bug, and a smaller test suite,
can be found in my bug report on RedHat's bugzilla (bug #57760).

> Mandrake and Redhat have been using gcc 2.96 for quite a long time now.
> Mandrake 8.0 and redhat 7.1 have it. But beware that these gcc's are heavily
> patched and evolved a lot.

Right.  This bug isn't in RH 7.1, and popped in RH 7.2.

> But beware that these gcc's are heavily patched and evolved a lot.

>From my point of view, they evolve from bad to worse :-)  
I miss the robust gcc 2.95.2 from RH 6.2 and Mandrake 7.2, which never
failed me.

- Xavier Leroy
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr