Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] notes about ocaml-3.0.4 on mac os x 10.1
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Damien Doligez <damien.doligez@i...>
Subject: Re: [Caml-list] notes about ocaml-3.0.4 on mac os x 10.1
Hi all,

>From: j h woodyatt <jhw@wetware.com>

>I noticed a few things that might be of interest to people using Mac OS 
>X 10.1:
>
>+ You still have to ignore the build failures around labltk-- no 
>surprise there.  I suppose there is a workaround for this if you're 
>willing to install XFree86, but I don't need one so I haven't looked for 
>it.  All the other tools build and install fine.

There must be some problem with the auto-config stuff because O'Caml
is not supposed to try to build labltk if TCL/TK is not installed.


>+ The opt.opt make target in ocaml-3.0.4 encounters a mysterious failure 
>with camlp4.  If no one on the Caml team has seen it, I'll happily help 
>track it down.

The mysterious failure is a stack overflow due to a recursive GC
function and a rather small stack limit on Mac OS 10.1.  You can get
around this problem by raising the stack limit or by using a smaller
minor heap (with OCAMLRUNPARAM), but you'll just encounter the next
problem: out-of-range relocations in the native code (same problem as
AIX).  We don't have a solution yet, so you should just skip the "make
opt.opt" step.


Anyway, here are the notes I took when building 3.04 on Mac OS 10.1:


-----------------

Objective Caml 3.04 was tested on a PowerMac G3 under Mac OS 10.1 with
the following software installed.  It should work without problem even
if you haven't installed these packages, but in that case you will not
have the graphics library nor the labltk library.

- fink 0.3.1 (package manager)
- tcl installed via fink
- XFree 4.1
- XDarwin 1.0a3
- OroborOSX 0.75 alpha3


To compile Objective Caml 3.04, follow the instructions in file INSTALL.
The following notes refer to the steps described in that file.

configure:
  To get labltk, you need to run ./configure with these options:
  ./configure -tkdefs -I/sw/include -tklibs -L/sw/lib

make world:
  do not worry about all the error messages in interp.c

make bootstrap: no comment

make opt: no comment

make opt.opt:
  This step is optional and it does not work (yet) on Mac OS 10.
  You should just skip it.

-- Damien
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr