Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] help. possible lablgl problem
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: paddym@m...
Subject: Re: [Caml-list] help. possible lablgl problem
Quoting David MENTRE <david.mentre@wanadoo.fr>:

> paddym@mailstop9.com writes:
> 
> > just used the default installation of GL that came with mandrake,
> which is
> > admittedly confusing.  libGL.la was came from Mesa-common-devel-3.4.1
> but
> > libGL.so came from XFree86-devel and the actual library libGL.so.1.2
> came from
> > XFree86-libs.  Thinking that GL was most likely my problem, I
> installed
> 
> You should use the GL libraries comming with your XFree. Look on the
> mesa web site for further info.
> 
> http://www.mesa3d.org/about/systems.html
>  If you download and install XFree86 4.0 you do not need to install
> Mesa
>  separately. All the important parts of Mesa will be installed with
> the
>  rest of XFree86.
> 
> 
> By the way, looking at your spinlock problem, what is the version of
> your glibc? At least one lock bug was fixed in the latest release.
> 
> Hope it helps,
> d.
> -- 
>  david.mentre@wanadoo.fr
> 

gcc-2.96, glibc-2.2.2-4, Xfree86-4.0.3, and GL (all from RPMS) came with
Mandrake.  I installed ocaml-3.04 from an RPM and build lablgl-0.97.  I upgraded
glibc to a different build (2.2.2-6), but it sounds like I need glibc-2.2.4, is
that correct?  Does anyone know a way to do this without changing distros, or is
changing versions going to be painful?  Thanks for any suggestions.

Patrick

-----------------------------------------------------------------
Get your own free mailbox at MailStop9! http://www.mailstop9.com/
-------------------
Bug reports: http://caml.inria.fr/bin/caml-bugs  FAQ: http://caml.inria.fr/FAQ/
To unsubscribe, mail caml-list-request@inria.fr  Archives: http://caml.inria.fr