English version
Accueil     À propos     Téléchargement     Ressources     Contactez-nous    
Browse thread
[Caml-list] Make opt in camlimages
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sven Luther <luther@l...>
Subject: Re: [Caml-list] Make opt in camlimages
On Sat, May 04, 2002 at 03:07:31PM +0200, Jun P.FURUSE wrote:
> > %sudo make installopt
> > make: *** No rule to make target `installopt'. Stop.
> > 
> > Is that normal ?
> > 
> > Thank you in advance, best regards,
> 
> Sorry, there was a bug inside INSTALL.
> Now, make install also installs the native code version.

Jun, i suppose you do know that not all arches support the native code
version. What will happen if i type make install on such an arch (i
don't know the camlimages makefile, but when typing make install on such
an arch in advi, it will try to install advi.opt as advi, which of
course will not work, since there is no advi.opt).

I, as a debian developper who has to have packages build on near to 11
different plateforms, half of whom without native code compiler, would
like very much that the installation of bytecode only is not forgotten
in the Makefiles.

If needed i can provide patches for it, but i think it is no big issues
for the authors of ocaml packages to take this fact into acount, and
write makefiles who will work for all arches without needing patching.

Anyway, thank you for your great work on camlimages and other stuff.

Friendly,

Sven Luther
-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners