Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
RE: [Caml-list] Namespace proposal
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: 2002-08-15 (17:00)
From: Vitaly Lugovsky <vsl@o...>
Subject: RE: [Caml-list] Namespace proposal
On Thu, 15 Aug 2002, Gurr, David (MED, self) wrote:

> My two cents worth: Please dont copy package ideas from 
> languages that lack functors.  And Java's package ==
> directory idea is far from beloved by all.  -D

 For me package is not a modules collection, but just
a way of multi-word module naming. It's not so easy to
give short and still adequate names to the modules, but
something like Db.Core.Storage looks much better then
Dbstorage, and Storage can still be accessed just as
"Storage" from modules of the same "package". Just a naming
way, nothing more.

To unsubscribe, mail Archives:
Bug reports: FAQ:
Beginner's list: