Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] Displaying Postscript?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sven Luther <luther@d...>
Subject: Re: [Caml-list] Displaying Postscript?
On Tue, Jan 28, 2003 at 01:48:32PM +0100, Jun P. FURUSE wrote:
> Hello,
> 
> > > One possibility is a combination of LablGtk and Camlimages 
> > > LablGtk provides a GUI and Camlimages is for image file manipulation.
> > > 
> > > Maybe you can also use gdkpixbuf interface of LablGtk instead of 
> > > Camlimages, but I am not really sure.
> > 
> > BTW, have you tested camlimages with the (alpha) lablgtk2 ?
> 
> Nope. Do you need it ?
>  
> > And is it still possible to build camlimages with libpng 2 ?
>  
> Yes, I still use libpng2-dev.

Well, the thing is, in debian, gnome 1 packages are linked against
libpng2, and gnome2 (including gtk2) packages are linked against
libpng3 (well, libpng12-0 actually). And you cannot have the devel
environment for both libpngs installed at the same time. Stefano builds
his camlimages with libpng3 though, and it uses the lablgtk packages. In
turn, lablgtk depends on libgtkxmhtml-dev, which depends on libpng2. I
thought that the correct way would be to have two camlimages, one which
uses lablgtk and libpng2, and the other which uses lablgtk2 and libpng3.

I am not sure, but mixing both libpngs in a same executable may cause
problems, maybe ...

Friendly,

Sven Luther
-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners