Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] ocaml-3.06 and tcl/tk-8.4
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: karlandtanya@earthlink.net <karlandtanya@e...>
Subject: [Caml-list] ocaml-3.06 and tcl/tk-8.4
Is there a patch to compile ocaml 3.06 with the current version of tcl/tk?

I try to compile with 

tcl-8.4.2
tclx-8.3.5
tix-8.1.4
tk-8.4.2

And get an error.  I read the manual and see:

"Unix: The labltk library is available for any system with Tcl/Tk
installed, starting from Tcl 7.5/Tk 4.1 up to Tcl/Tk 8.3. Beware that some
beta versions may have compatibility problems"

and the error I get is:

cltkImg.c: In function `camltk_setimgdata_native':
cltkImg.c:102: too few arguments to function `Tk_PhotoPutBlock'
make[2]: *** [cltkImg.o] Error 1


One solution is clear:  tcl/tk 8.3.  I would like to keep my current
version of tcl/tk.  Is there a way to compile ocaml with labltk support
using tcl/tk 8.4?  How can I do this?

Thank you very much,


Karl Pizzolatto

--------------------------------------------------------------------
mail2web - Check your email from the web at
http://mail2web.com/ .


-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners