Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[Caml-list] ANNOUNCE: perl4caml 0.3.0 - Call Perl libraries from OCaml
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Richard Jones <rich@a...>
Subject: [Caml-list] ANNOUNCE: perl4caml 0.3.0 - Call Perl libraries from OCaml

I'm pleased to announce the first working release of perl4caml
(0.3.0).  This small wrapper allows you to call Perl libraries from
Objective CAML programs.

There is a low-level interface which allows you to call or evaluate
Perl directly, and there are high-level object-oriented interfaces to
some CPAN libraries.  Currently I have wrapped libwww-perl
(LWP::UserAgent), HTTP::* and the Google API (Net::Google), because
these are what I'm using.  I hope that other people can contribute
high-level wrappers to any Perl libraries they might find useful -
wrappers are quite easy to write.

Perl4caml is distributed under GNU LGPL with the OCaml linking

You can get it here:


Richard Jones.
Merjis Ltd. - all your business data are belong to you.

To unsubscribe, mail Archives:
Bug reports: FAQ:
Beginner's list: