Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] Building camlimages programs on deb (and linux)
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jun.Furuse@i...
Subject: Re: [Caml-list] Building camlimages programs on deb (and linux)
Hello,
 
> ocamlc `camlimages-config` -cclib "-L/usr/X11R6/lib -lxvthumb -lXpm 
> -lX11 -lpng -lfreetype -lz -ljpeg -lgif"

Duh, I cannot tell what is wrong. Even we, the authors, do not know
about the script "camlimages-config". It is not from  the official
camlimages distribution. (I guess it comes from Debian package, which
is out of my control.) 

I always use $(CAMLIMAGESLIBS) defined inside
/usr/local/lib/ocaml/camlimages/Makefile.config for linking the
camlimages to my programs. It should list all the libraries required.

BTW, it sounds still strange that you fail to link even with -lX11.
Please send me what happens (including error messages) if you execute
the following:

	ocamlc -custom -verbose `camlimages-config` 
	-cclib "-L/usr/X11R6/lib -lxvthumb -lXpm 
	-lX11 -lpng -lfreetype -lz -ljpeg -lgif"

> If i leave ci_xpm.cma off, it links.  I don't know if it's safe to leave 
> it off.  I suppose if I don't use XPM it'll be ok, but it's not the 
> greatest solution.

Camlimages libraries are separated into pieces so that you can link
the libraries you really want. If you are not interested to read/write
xpm images in your program, you need not to link ci_xpm.cma.

Anyway, you found a bug of camlimages. Usually Xpm requires X11, but I
forgot to link it. I will fix the problem.

--
Jun

-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners