Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] camlimages jpeg mac os x
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Shivkumar Chandrasekaran <shiv@e...>
Subject: Re: [Caml-list] camlimages jpeg mac os x

I think I found an easy way to configure properly in a bash shell:

CFLAGS=-I/sw/include LDFLAGS=-L/sw/lib ./configure

did the trick for me. Thanks,

--shiv--



On May 18, 2004, at 4:49 PM, William Neumann wrote:

> On May 18, 2004, at 3:06 PM, Shivkumar Chandrasekaran wrote:
>
>> I am trying to install camlimages on mac os x. I am not able to get 
>> "./configure" to recognize that I do have libjpeg installed. I have 
>> jpeg (tiff, png, etc.) installed in /sw/lib using fink. The configure 
>> script does not seem to give me any option for setting the directory 
>> where libjpeg is located. I tried creating a symbolic link in 
>> /usr/lib but that did not help either.
>>
>> Any advice? Thanks,
>
> Oddly enough I just compiled camlimages on OS X this afternoon...
>
> You need to create the links in /usr/local/lib (or change the prefix 
> that the configure script uses, but then you'll miss the stuff that's 
> already in /usr/local/lib).  Don't forget to make links to jpegjib.h, 
> jconfig.h, jmorecfg.h, and jerror.h (I think those are the files, just 
> search /sw/include for j*.h) in /usr/local/include.
>
> Best of luck.
>
> William D. Neumann
>
> "Here come the bunnies with the sugar water,
>  Do a little dance with the farmer's daughter."
>
> 		-- The Halo Benders

-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners