Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[Caml-list] GODI news
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Gerd Stolpmann <info@g...>
Subject: [Caml-list] GODI news
Hi caml-list,

today the GODI distribution releases a new stable version of the
bootstrap tarball. This version includes support for:

- Linux
- Solaris
- FreeBSD
- NetBSD
- MacOS X
- Cygwin

The latter four OS are supported for the first time. Read below how to
install or upgrade GODI.

There are also new packages, in particular:

- apps-unison: File synchronizer
- godi-camltemplate: Templates to generate web pages, SQL queries etc.
- godi-camomile: A comprehensive Unicode library
- godi-ocaml-mysql: MySQL client bindings
- godi-xml-light: minimal XML parser & pretty printer

Many thanks to Alain Frisch, Benjamin Geer, Owen Gunden, and Yamagata
Yoriyuki, who created the packages.

How to install GODI for the first time: Download the new bootstrap

Please read these web pages and follow the instructions:

The latter is also included in the tarball.

How to upgrade: Just start godi_console, update the build instructions,
and then select the packages to upgrade from the list. Include at least
godi-core-mk, godi-core-pkgtools, and godi-tools, or press 'u' to select
all for which an upgrade is available. Then continue as usual. The rest
is done automatically. (This is why you need GODI.)

Gerd Stolpmann * Viktoriastr. 45 * 64293 Darmstadt * Germany

To unsubscribe, mail Archives:
Bug reports: FAQ:
Beginner's list: