Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] Why I cannot open a graph with a specific title
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Matt Gushee <mgushee@h...>
Subject: Re: [Caml-list] Why I cannot open a graph with a specific title
On Mon, Jun 28, 2004 at 10:50:22PM +0200, Christophe TROESTLER wrote:
> 
> Please read the manual:
> 
>            open_graph "foo:0"  connects to the display foo:0 and creates a
>              window with the default geometry 

Okay, but can you explain why

  # open_graph "localhost:0";;

fails on my Linux box? If I do 

  $ xhost +localhost

before starting the OCaml toplevel, it raises an exception. If not, it
causes OCaml to die with Signal 13 (SIGPIPE).

I suppose it's redundant to specify "localhost:0," but I don't see a
good reason why it shouldn't work.

-- 
Matt Gushee                 When a nation follows the Way,
Englewood, Colorado, USA    Horses bear manure through
mgushee@havenrock.com           its fields;
http://www.havenrock.com/   When a nation ignores the Way,
                            Horses bear soldiers through
                                its streets.
                                
                            --Lao Tzu (Peter Merel, trans.)

-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners