Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[Caml-list] Compatibility between versions
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Mary Fernandez <mff@r...>
Subject: [Caml-list] Compatibility between versions

I have a software package that contains .cmi files compiled with 3.07.
I am trying to compile a source .ml file, which refers
to the 3.07 compiled interfaces, using the 3.08 compiler.
For each of the 3.07 .cmi files, I get the error message:

"foo.cmi is not a compiled interface"

Is this error due to using two different compiler versions?

I'm recompiling my software package using 3.08 to answer
this question but hoped someone could give me a quick answer.
Mary Fernandez <>
AT&T Labs - Research

To unsubscribe, mail Archives:
Bug reports: FAQ:
Beginner's list: