Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[Caml-list] ANNOUNCE: mod_caml 1.2.0 released
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Richard Jones <rich@a...>
Subject: [Caml-list] ANNOUNCE: mod_caml 1.2.0 released
mod_caml is a set of Objective CAML (OCaml) bindings for the Apache
API.  It allows you to run CGI "scripts" written in OCaml directly
inside the Apache webserver.  It also gives you a fairly complete set
of bindings to the Apache API and Apache request cycle.

Main change in release 1.2.0:

* This version should be completely independent of OCamlDBI[1].  To
  achieve this, the DBI pooling code has been "functorized" (see
  previous discussion on caml-list).

  You will now need to load DBI modules explicitly, since they are
  no longer linked into  For example, if you were
  using PostgreSQL, you'd add the following lines to your Apache conf:

  CamlLoad /usr/lib/ocaml/3.07/postgres/postgres.cma
  CamlLoad /usr/lib/ocaml/3.07/dbi/dbi.cma
  CamlLoad /usr/lib/ocaml/3.07/dbi/dbi_postgres.cmo


[1] Note that although this release is independent of OCamlDBI, if you
_do_ want to use OCamlDBI in conjunction with this release, then you
must use version >= 0.9.8.

Richard Jones.
Merjis Ltd. - improving website return on investment
Perl4Caml lets you use any Perl library in your type-safe Objective
CAML programs.

To unsubscribe, mail Archives:
Bug reports: FAQ:
Beginner's list: