Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] mod_caml makes Apache segfault
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Alan Schmitt <alan.schmitt@p...>
Subject: [Caml-list] mod_caml makes Apache segfault
Hi,

In order to play with cocanwiki, I am currently trying to get mod_caml 
to work on a server here (Fedora Core 1, Apache 2.0.50).

First of all, a small trick: in order to get mod_caml to compile, I had 
to specify two paths for includes:
PACHEINCDIR := /usr/include/httpd -I /usr/include/apr-0

I think this is a bug from RedHat (there is a apr.h included from 
httpd.h without the correct include path).

I have installed mod_caml following the instruction, added a 
"LoadModule" line in the config file:
LoadModule caml_module modules/mod_caml.so
and restarted httpd.

The problem is that now Apache does not serve any pages, and I see in 
the logs a bunch of:

[Mon Sep 06 14:46:43 2004] [notice] child pid 26207 exit signal Segmentation fault (11)
[Mon Sep 06 14:46:43 2004] [notice] child pid 26209 exit signal Segmentation fault (11)
[Mon Sep 06 14:46:52 2004] [notice] child pid 26210 exit signal Segmentation fault (11)

Does someone know how to get mod_caml to work on such FC1 with Apache 2?

Thanks a lot,

Alan Schmitt

-- 
The hacker: someone who figured things out and made something cool happen.
.O.
..O
OOO