Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] Announcing the OMake build system version 0.9.1
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jacques GARRIGUE <garrigue@k...>
Subject: Re: [Caml-list] Announcing the OMake build system version 0.9.1
From: james woodyatt <jhw@wetware.com>
> On 05 Sep 2004, at 13:38, Aleksey Nogin wrote:
> > On 04.09.2004 18:18, james woodyatt wrote:
> >>
> >> OMake looks good, but it is GPL which prevents me from using it 
> >> until it is a widely distributed and mature product.
> >
> > Could you please explain what kinds of things you might want to do and 
> > what license(s) would be needed to make it possible?
> 
> I want to be able to extend the functions so that my build system knows 
> how to use more toolchains than just C and Ocaml, and I want those 
> extensions to be bundled with my non-GPL code.  If I were to use Omake, 
> then I expect my code would link to the functions in the Omake 
> distribution, and I would then be in violation of the GPL if I didn't 
> use a GPL-compatible license for my distribution.

Looks like you make the classical confusion:
1) You have every right to use several (even incompatible) licenses in
   the same distribution (ocaml does it). The only restriction is that
   all code linked inside a GPLed tool must be provided under a
   GPL-compatible license.
2) For code you wrote yourself, you are also free to distribute it
   under several (even incompatible) licenses. So you can reuse your
   extension code in another project (I don't know exactly how if this
   code was intended for omake, but you can), without caring about the
   GPL.

So I don't see how the fact a tool is distributed under the GPL could
limit your ability to use it (and improve it).
The only problem you might have is if you want to link omake itself
with an existing library, and you cannot/would not provide it under a
GPL-compatible license. But I don't see what kind library it would be.

Jacques Garrigue

-------------------
To unsubscribe, mail caml-list-request@inria.fr Archives: http://caml.inria.fr
Bug reports: http://caml.inria.fr/bin/caml-bugs FAQ: http://caml.inria.fr/FAQ/
Beginner's list: http://groups.yahoo.com/group/ocaml_beginners