Version française
Home     About     Download     Resources     Contact us    
Browse thread
FW: [Caml-list] mod_caml makes Apache segfault
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Richard Jones <rich@a...>
Subject: Re: FW: [Caml-list] mod_caml makes Apache segfault
On Tue, Nov 09, 2004 at 06:15:52PM -0800, HENRIKSON, JEFFREY wrote:
> Hello,
> 
> I am also trying to install mod_caml.  (and wiki next . . .)  Starting
> with the 2.0.52 debian apache2.  I know about this patch:
> 
> http://issues.apache.org/bugzilla/showattachment.cgi?attach_id=10734
> 
> But my debian package is applying a similar (same?) patch during
> installation.  
> 
> When loaded, I get a segfault on any page load, static or dynamic.  The
> backtrace is below.  Ideas?  Things which I have noticed:
> 
> - The debian pcre rename patch left a few symbols pcre_ without
> ap_pcre_.
> 
> - Googling mod_caml_get_dir_config gives a chat room discussion of
> somebody having the same issue with apache 1.3.

Looks like you're using a multi-threaded instance of Apache?  mod_caml
is completely untested in such an environment, and probably doesn't
work.  Can you try a pre-forking model instead and see if that fixes
the problem?

Rich.

-- 
Richard Jones.  http://www.annexia.org/  http://www.j-london.com/
>>>   http://www.team-notepad.com/ - collaboration tools for teams   <<<
Merjis Ltd. http://www.merjis.com/ - improving website return on investment
Use Perl libs in OCaml - http://www.merjis.com/developers/perl4caml