Version française
Home     About     Download     Resources     Contact us    
Browse thread
OpenGL support in LablGTK2?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jacques Garrigue <garrigue@m...>
Subject: Re: [Caml-list] OpenGL support in LablGTK2?
From: Sven Luther <sven.luther@wanadoo.fr>
> > Now, it seems that the gtk people have botched something, and gtkglarea
> > have stopped working. If this is not solved soon, I suppose lablgtk2
> > will have to move to gtkglext, and emulate gtkglarea on top of it (you
> > don't want API changes, do you?)
> 
> Notice that this is not really true, look at the debian lablgtk2 package, it
> builds against lablgl, and everything works fine.
> 
> Well, at least the GL examples work with lablgtk2. Lablgtk2 uses the
> libgtkgl2.0-dev package instead of the older gtkglarea ones though, but it
> seems to be the same stuff : 

As far as I can see, what you call libgtkgl2.0 happens to be what
others call gtkglarea-1.99, i.e. the gtk2-ized version of gtkglarea.
It seems that we are a few here experiencing problems with this
version and very recent versions of gtk2 (in my case, gtk-2.4.13).
So maybe you are not using the same version of gtk, or the debian
people have already solved the problem, or actually the cause is
different altogether (hard to guess).

Jacques Garrigue