Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: OpenGL support in LablGTK2?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sven Luther <sven.luther@w...>
Subject: Re: [Caml-list] Re: OpenGL support in LablGTK2?
On Tue, Dec 07, 2004 at 12:18:28PM +0100, =?ISO-8859-1?Q? Gr=E9gory?= Guyomarc'h wrote:
> I don't know what the current status of the GtkGlArea project actually
> is, however you can still grab gtkglarea from Gnome's anonymous ftp:
> ftp.gnome.org. The latest version (1.99) does not work with my recent
> Gtk2 installation. There is another GL support library for gtk2 with
> which I have no problem: the Gtk GL Extension (the project seems more
> active than the gtkglarea project, it also provides more
> functionalities), you can get it at
> 
>    http://gtkglext.sourceforge.net/
> 
> If it helps, I have a straightforward ocaml bindings for part of this
> library, you can get it at
> 
> http://gregory_guyomarch.imap-mail.com/code/ocaml-gtkglext-0.1.tar.gz
> 
> It has not been widely tested, but I have been using it for some time
> and it works fine for me.

Package: liblablgtk2-ocaml
Priority: optional
Section: libs
Installed-Size: 460
Maintainer: Sven Luther <luther@debian.org>
Architecture: powerpc
Source: lablgtk2
Version: 2.4.0-2
Depends: ocaml-base-3.08, libart-2.0-2 (>= 2.3.16), libatk1.0-0 (>= 1.6.0),
libbonobo2-0 (>= 2.6.2), libbonoboui2-0 (>= 2.5.4), libc6 (>= 2.3.2.ds1-4),
libgconf2-4 (>= 2.6.2), libglade2-0 (>= 1:2.3.6), libglib2.0-0 (>= 2.4.1),
libgnome2-0 (>= 2.6.0), libgnomecanvas2-0 (>= 2.6.0), libgnomeui-0 (>= 2.6.0),
libgnomevfs2-0 (>= 2.6.0), libgtk2.0-0 (>= 2.4.4), libgtkgl2.0-1, libice6 |
xlibs (>> 4.1.0), liborbit2 (>= 1:2.10.0), libpanel-applet2-0 (>= 2.6.2),
libpango1.0-0 (>= 1.4.0), libpopt0 (>= 1.7), librsvg2-2 (>= 2.7.2), libsm6 |
xlibs (>> 4.1.0), libxml2 (>= 2.6.11), xlibmesa-gl | libgl1, xlibmesa-glu |
libglu1, zlib1g (>= 1:1.2.1)

So, it works well with both lablgtk2 and gnome 2 or whatever. It uses libgtkgl
though. Ah, yes i use this as build-dependencies : 

Source: lablgtk2
Section: libdevel
Priority: optional
Maintainer: Sven Luther <luther@debian.org>
Build-Depends: debhelper (>> 3.0.0), ocaml-3.08, libncurses5-dev,
xlibs|xlib6g, debhelper, libgtk2.0-dev, libgtkgl2.0-dev, libglade2-dev,
liblablgl-ocaml-dev (>= 1.01-1), librsvg2-dev, libgnomecanvas2-dev, dpatch
Standards-Version: 3.6.1

$ apt-cache show libgtkgl2.0-dev
Package: libgtkgl2.0-dev
Priority: optional
Section: libdevel
Installed-Size: 112
Maintainer: Marcelo E. Magallon <mmagallo@debian.org>
Architecture: powerpc
Source: gtkgl2
Version: 1.99.0-2
Provides: gtkgl-dev
Depends: libgtkgl2.0-1 (= 1.99.0-2), libgtk2.0-dev
Conflicts: gtkgl-dev
Filename: pool/main/g/gtkgl2/libgtkgl2.0-dev_1.99.0-2_powerpc.deb
Size: 22520
MD5sum: ed959d5f50ad40764c945e7c04bf6b55
Description: Gimp Toolkit OpenGL area widget include files and static library
 A GTK widget for use with Mesa, an unlicensed OpenGL clone.  A Mesa
 development package is also required.

$ more /usr/share/doc/libgtkgl2.0-dev/copyright
This package was debianized by Drake Diedrich <Drake.Diedrich@anu.edu.au> on
Thu, 24 Sep 1998 16:47:45 +1000.

It was originally downloaded from
   http://www.ece.ucdavis.edu/~kenelson/gtk-glarea/
Version 1:0.6 was downloaded from
   http://www.student.oulu.fi/~jlof/gtkglarea/download/

Copyright:

GtkGLArea
---------
...


So this is just the new version of gtkglarea for gtk2 or somethign such.

Hope this helps.

Friendly,

Sven Luther