Version française
Home     About     Download     Resources     Contact us    
Browse thread
OpenGL support in LablGTK2?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sven Luther <sven.luther@w...>
Subject: Re: [Caml-list] OpenGL support in LablGTK2?
On Thu, Dec 09, 2004 at 09:36:19AM +0900, Jacques Garrigue wrote:
> From: Sven Luther <sven.luther@wanadoo.fr>
> 
> > > What exactly are the problems ? During the build of libgtkgl2, or
> > > during the build of lablgl ? 
> > 
> > Both gtkgl2 and lablgl build without problems, so you may well want
> > to look at the debian packages for the source of your problem. (Or
> > simply run debian). 
> 
> This is not a build problem, but an execution problem.
> Here is the message:
>   The program 'lt-gtkglarea_demo' received an X Window System error.
>   This probably reflects a bug in the program.
>   The error was 'BadMatch (invalid parameter attributes)'.
> 
> I don't know exactly what causes it. Maybe a problem with xorg (I
> switched recently), or with leftover libraries...

This may be it, i still run Debian's highly modified XFree86 4.3.0.

> But lablGL itself works fine (with both Togl and glut)

Ok.

> (And no, I have no plan to run debian :-)

Well, the suggestion was just so you can test it, and do a comparative study
of both systems, but if you don't like debian, your loss.

Friendly,

Sven Luther