Version française
Home     About     Download     Resources     Contact us    
Browse thread
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jon Harrop <jon@j...>
Subject: Re: [Caml-list] (no subject)
On Tuesday 18 January 2005 07:33, Stéphane Payrard wrote:
> Hi,
>
> I am an ocaml beginner and I try to compile the last snapshot of
> camelon. I am using mandrake with the following rpms:
>    ocaml-lablgtk-1.2.7-1mdk
>    ocaml-3.08.2-1mdk
>
> I get the following message when trying to compile:
>
> Files /usr/lib/ocaml/lablgtk/gtkThread.cmx
> and /usr/lib/ocaml/threads/threads.cmxa
> make inconsistent assumptions over implementation Thread
>
> Should I use different versiosn of either lablgtk or ocaml?
> The INSTALL file suggest OCaml 3.07  and LablGtk 1.2.6 .
> Or is there an easy way to tweak cameleon to get it to compile
> with the ocaml and lablgtk versions I have.

I think this problem is due to different ocaml versions being used to generate 
lablgtk and threads.

Interfaces between OCaml compilation units are *very* brittle. This is being 
discussed on the list at the moment, as even a minor version change of the 
compiler (e.g. 3.08.2 -> 3.08.3) breaks compatibility.

The good news is that this binary incompatibility is because the compiler is 
very pedantic about interfaces and guarantees that everything will work.

Your best bet is either to compile all of the packages yourself or to use 
someone else's packages. I find Debian to be excellent in this respect.

Cheers,
Jon.

PS: 3.08 has some useful additions which you may well find that people use in 
their code now (e.g. immediate objects).