Version française
Home     About     Download     Resources     Contact us    

This site is updated infrequently. For up-to-date information, please visit the new OCaml website at

Browse thread
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: <matthieu.dubuget@l...>
Subject: tuareg,_windows,_cygwin_and_startxwin.bat

I use Ocaml (MSVC version) on windows XP Pro.
I experienced a strange behaviour of tuareg's
tuareg-run-ocaml command, depending on the way I call cygwin
and emacs. If anybody knows the reason of this behaviour, I
would be interested for an explanation.

When I call a toplevel this way, everything works ok :
- run cygwin
- startx 
- run emacs from xterm
- launch toplevel with the tuareg-run-caml command

When I work this way (I prefer this way, because it is
simpler, and do not leave an unused opened cygwin terminal):
- run xwindows directly with startxwin.bat script
- run emacs from xterm
- launch toplevel with the tuareg-run-caml command

    -> the toplevels runs in a separate windows which is
annoying, because I then lack the power of emacs...

- If I launch a customized toplevel of mine, it runs as
usual inside the *caml-toplevel* buffer

Any idea ?

Thanks in advance

************************ ADSL JUSQU'A 8 MEGA + 3 MOIS DE TELEPHONE GRATUIT ************************
L'ultra haut débit à 15EUR/mois seulement ! Et vous téléphonez gratuitement en France vers les postes fixes,
hors numéros spéciaux pendant 3 mois.
Pour profiter de cette offre exceptionnelle, cliquez ici :  (voir conditions sur le site)