Version française
Home     About     Download     Resources     Contact us    
Browse thread
[Caml-list] Building a custom compiler environment
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jonathan Roewen <jonathan.roewen@g...>
Subject: [Caml-list] Building a custom compiler environment
Hi,

I'm trying to compile a custom 3.09.0 environment, using the system
ocaml compilers (some 3.08 version).

Is it not possible to compile the tools and things with 3.08? I get
the following error:

ocamlc -warn-error A -I utils -I parsing -I typing -I bytecomp -I
driver -I toplevel -c typing/typecore.ml
File "typing/typecore.ml", line 748, characters 12-29:
Unbound value Printf.sub_format
make[1]: *** [typing/typecore.cmo] Error 2

I've had a look in a 3.08 branch, and this function doesn't appear to
exist; however, I see it is present in the 3.09 source tree.

I suppose the only option is to install 3.09 as system ocaml tools?

Kindest Regards,

Jonathan