Version française
Home     About     Download     Resources     Contact us    
Browse thread
Link errors with O'Caml 3.09 and Camlidl 1.05
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Kathleen Fisher <kfisher@r...>
Subject: Link errors with O'Caml 3.09 and Camlidl 1.05
We installed O'Caml 3.09 on MacOS 10.4 from the .dmg image, then  
installed
Camlidl with no errors.  When we link our Camlidl test program,
we get the link errors below.  However, when we install OCaml 3.09
from source, compile it, and install Camlidl, we do not get
any link errors.

Can someone explain this behavior?

Thanks!
Kathleen Fisher

/usr/local/bin/ocamlc -I /usr/local/lib/ocaml -cc cc -custom -o test  
test.cmo test_stubs.o test.o test_idl.cmo /usr/local/lib/ocaml/ 
libcamlidl.a
ld: Undefined symbols:
_sprintf$LDBLStub
_fprintf$LDBLStub
_sscanf$LDBLStub
Error while building custom runtime system
make: *** [all] Error 2