Version française
Home     About     Download     Resources     Contact us    
Browse thread
Re: [Caml-list] Crashing X.Org with lablgl
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: David Thomas <david_hd@y...>
Subject: Re: [Caml-list] Crashing X.Org with lablgl

--- Jacques Garrigue <garrigue@math.nagoya-u.ac.jp>
wrote:

> From: David Thomas <david_hd@yahoo.com>
> 
> > > Sending me the complete source to try to
> > > reproduce the problem?
> > 
> > ftp://tirnanogth.dyndns.org/pub/mrlplot.tar.gz
> 
> Thanks, but how can I reproduce the problem?
> The included datafile is empty, so I don't even now
> the format...

Updated with a proper datafile.  The program should be
run as:

mrlplot -file datafile

On every system where I've seen it crash, it's
predictably crashed within about a minute of starting,
although it does not seem to be a a fixed interval.

As to the program in general, rotate with the mouse or
with WASDQ and E, use ESC to quit.

> But Erik seems to be very competent on both openGL
> and lablGL, while I'm only on the second, so he
might 
> help you better if this is not a lablGL problem 
> proper.

Alright.
 
> By the way there's something slightly strange in
> your Makefile: you have -I +lablgl and -I +lablglut,

> while on a standard installation this should be only

> a single -I +lablGL. 

Hmm... seems to work either way, I'll use that one
going forward.

> What version are you using?  And as other suggested,

> what version of X.org. I remember that some version 
> had a compatibility problem gtkglarea, but then this

> is not what you are using.

Ocaml version 3.08.3
X.org version 7.1


 
____________________________________________________________________________________
The fish are biting. 
Get more visitors on your site using Yahoo! Search Marketing.
http://searchmarketing.yahoo.com/arp/sponsoredsearch_v2.php