Version française
Home     About     Download     Resources     Contact us    
Browse thread
Crashing X.Org with lablgl
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Conrad Hughes <conrad.hughes@e...>
Subject: Re: [Caml-list] Crashing X.Org with lablgl

[slightly off-topic, but:]

Vu Ngoc San> I install manually the nvidia driver with
Vu Ngoc San> ./NVIDIA-Linux-x86-1.0-8756-pkg1.run
[..]
Vu Ngoc San> I suspect that debian packages overwrite some libs that become 
Vu Ngoc San> incompatible with my nvidia kernel installation.

More the other way around, but yes, the NVIDIA driver binary install
even explicitly mentions that it overwrites some original X install
files.  Why don't you use the official Debian NVIDIA packages?  1.0-8776
is in testing and unstable, and 1.0.9746 is in experimental.  If you
want to run stable and are not familiar with mixing in bits from other
versions of Debian, you should read "man apt_preferences" for a start.
Adding (say) experimental to your sources.list, and something like

  Package: nvidia-*
  Pin: release o=Debian,a=experimental
  Pin-Priority: 991

to your /etc/apt/preferences should get you going.

Conrad