Version française
Home     About     Download     Resources     Contact us    
Browse thread
No caml_startup in 3.10? Where is it?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Joel Reymont <joelr1@g...>
Subject: Re: No caml_startup in 3.10? Where is it?
It's a foot in mouth kind of an issue, or wrong instructions to be  
precise.

The makefile generated by Ruby's mkmf needs to use libfib.a and it  
also needs -lcurses on Linux.

On Mar 28, 2007, at 9:44 PM, Joel Reymont wrote:

> I followed the instructions [1] on Ubuntu Edgy and got the same error.
>
> The symbols do exist which makes the problem more baffling.
>
> nm libasmrun.a |grep startup
> libasmrun.a(startup.o):
> 000003dd T _caml_startup
>
> nm libcamlrun.a |grep startup
> libcamlrun.a(startup.o):
> 00000aa2 T _caml_startup_code

--
http://wagerlabs.com/