Version française
Home     About     Download     Resources     Contact us    
Browse thread
Cygwin, OCaml 3.10 and dllunix
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Philippe Wang <lists@p...>
Subject: Re: [Caml-list] Cygwin, OCaml 3.10 and dllunix
Joel Reymont wrote:
> How would I resolve this error under Cygwin?
>
> /usr/local/lib/ocaml/unix.cma: loaded
> Cannot load required shared library dllunix.
> Reason: dllunix.so: dynamic loading not supported on this platform.
> /usr/local/lib/ocaml/site-lib/oUnit: added to search path
> /usr/local/lib/ocaml/site-lib/oUnit/oUnit.cma: loaded
> Reference to undefined global `Unix'
>
>     Thanks, Joel
>
>
> -- 
> http://topdog.cc      - EasyLanguage to C# compiler
> http://wagerlabs.com  - Blog

Hi,

It seems you want to load modules with the top level ("ocaml" command), 
but your system doesn't allow dynamic loading...

So I suggest you to use ocamlmktop.
It allows you to create a toplevel with the required libraries.

http://caml.inria.fr/pub/docs/manual-ocaml/manual023.html#htoc113

--
Philippe Wang
  mail[at]philippewang.info