Version française
Home     About     Download     Resources     Contact us    
Browse thread
camlp4 can't find camlp4/Camlp4Parsers path?
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Nicolas Pouillard <nicolas.pouillard@g...>
Subject: Re: [Caml-list] camlp4 can't find camlp4/Camlp4Parsers path?
Excerpts from Richard Jones's message of Fri Aug 10 10:35:04 +0200 2007:
> On Thu, Aug 09, 2007 at 08:30:10PM +0200, Nicolas Pouillard wrote:
> > When did you get this kind of error?
> > 
> > Is your camlp4 installed in the expected directory (camlp4 -where)?
> 
> $ camlp4 -where
> /usr/lib/ocaml/camlp4
> 
> > If it's a manual compilation command the recommended flag is
> > ``-I +camlp4/Camlp4Parsers''.
> 
> I don't understand.  Are you saying that I must add this flag?  I've
> never had to add this flag manually before when compiling camlp4
> stuff, and nor do a lot of the packages I'm trying to install add this
> flag.

Sorry, this flag is required by **ocamlc** when compiling with camlp4 parsers.

However camlp4 itself should not requires this kind of extra flags. It's certainly a bug, what's the exact situation?

-- 
Nicolas Pouillard aka Ertai