Version française
Home     About     Download     Resources     Contact us    
Browse thread
Camlp5 release 5.03
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Stefano Zacchiroli <zack@b...>
Subject: Re: [Caml-list] Camlp5 release 5.03
On Wed, Nov 21, 2007 at 05:19:48PM +0000, Richard Jones wrote:
> If you had a package which depends on camlp4 in 3.09.3, you need to
> modify it so it compiles with OCaml 3.10.  An alternative which
> doesn't involve modifying your package is to install camlp5.

That's not true. Camlp5 had its normal evolution as a software project
and, as it happens to avoid hindering software evolution, has also
introduced non backward compatible changes. In several case it is simply
not a drop-in replacement for the camlp4 pre-3.10.

Still, the non backward compatible changes are (in my experience) well
documented by Daniel, and it's easier to forward port applications from
camlp4 pre-3.10 to camlp5 than to make the jump from camlp4 pre-3.10 to
camlp4 3.10.

Cheers.

-- 
Stefano Zacchiroli -*- PhD in Computer Science ............... now what?
zack@{cs.unibo.it,debian.org,bononia.it} -%- http://www.bononia.it/zack/
(15:56:48)  Zack: e la demo dema ?    /\    All one has to do is hit the
(15:57:15)  Bac: no, la demo scema    \/    right keys at the right time