English version
Accueil     À propos     Téléchargement     Ressources     Contactez-nous    
Browse thread
Re: ocamlgsl-0.6.0. fails to compile on ubuntu
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Sylvain Le Gall <sylvain@l...>
Subject: Re: ocamlgsl-0.6.0. fails to compile on ubuntu
On 12-11-2007, Olivier Andrieu <oandrieu@nerim.net> wrote:
> Hi,
>
> On Nov 12, 2007 1:06 PM, Mikhalev, Alex <a.mikhalev@cranfield.ac.uk> wrote:
>>
>>
>>
>> Dear All,
>>  Any help will be appreciated as well as suggestion to any docs or
>>  tutorial (I have seen README and website). All error messages and system
>>  configuration below.
>>  Regards,
>>  Alex
>>  >tar zxvf ocamlgsl-0.6.0.tar.gz
>>  >cd ocamlgsl-0.6.0/
>>  >make
>>  /ocamlgsl-0.6.0$ make
>>  /bin/sh: gawk: not found
>>  /bin/sh: gawk: not found
>>  /bin/sh: gawk: not found
>>  Makefile:100: mingw.mak: No such file or directory
>>  /bin/sh: gawk: not found
>>  make: *** No rule to make target `mingw.mak'. Stop.
>>  >sudo aptitude install gawk
>>  Setting up gawk (3.1.5.dfsg-4build1) ...
>
> indeed, you need awk.
>
>>  >make
>>  ....
>>  ocamlc -ccopt ' -DHAVE_INLINE -DHAVE_FENV -g -O2 ' -c mlgsl_eigen.c
>>  mlgsl_eigen.c: In function 'ml_gsl_eigen_nonsymm_alloc':
>>  mlgsl_eigen.c:152: error: 'gsl_eigen_nonsymm_workspace' undeclared
>>  (first use in this function)
>
> that's because your version of GSL is too old: ocamlgsl 0.6.0 requires GSL 1.9.
> Either upgrade your GSL or use a previous version of ocamlgsl.
>
> Btw I'm pretty sure Debian has a package for ocamlgsl ...
>

Debian has ocamlgsl 0.6.0, and it build-depends on gawk (and libgsl0)

Build-Depends: cdbs (>= 0.4.23-1.1), debhelper (>= 5), dpatch, ocaml-nox
(>= 3.10.0-9), ocaml-findlib (>= 1.1.2pl1-4), libgsl0-dev, chrpath,
gawk, dpkg-dev (>= 1.13.19), camlp4 (>= 3.10.0)

http://packages.qa.debian.org/o/ocamlgsl.html
http://buildd.debian.org/pkg.cgi?pkg=ocamlgsl

(libgsl0 is 1.9)

Ubuntu people can take a look at build log, if they want to see
everything which is require to build ocamlgsl (using ocaml 3.10.0)

Regards,
Sylvain Le Gall