Version française
Home     About     Download     Resources     Contact us    
Browse thread
Floating exception
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Jon Harrop <jon@f...>
Subject: Re: [Caml-list] Smoke on 3.09.2
On Sunday 25 November 2007 08:26, Vu Ngoc San wrote:
> Le Saturday 24 November 2007 23:36:24 Jon Harrop, vous avez écrit :
> > I tried to reply to this on-list but my response hasn't appeared. Can you
> > try compiling the free bytecode version from:
> >
> >   http://www.ffconsultancy.com/products/smoke_vector_graphics/free.html
>
> I'm sorry I can't because kubuntu gutsy is shipped with ocaml 3.09.2
> and you provide 3.09.1.
>
> So I get:
>
> Files graphics2D.cma(Utility) and /usr/lib/ocaml/3.09.2/stdlib.cma(Array)
> make inconsistent assumptions over interface Array

Sorry, I was working on the assumption that OCaml only breaks compatibility on 
minor updates. I'll install 3.09.2 and build a free edition of Smoke just for 
you. :-)

Is it really necessary for OCaml to break compatibility on minor-minor 
releases like this?

-- 
Dr Jon D Harrop, Flying Frog Consultancy Ltd.
http://www.ffconsultancy.com/products/?e