Version française
Home     About     Download     Resources     Contact us    
Browse thread
ANNOUNCE: OCaml in Fedora & Red Hat
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Richard Jones <rich@a...>
Subject: ANNOUNCE: OCaml in Fedora & Red Hat
This is an update about the state of OCaml in Fedora, one of a very
occasional series (the last update that I posted here was over 6
months ago).

Fedora 8 was released at the end of last year with OCaml 3.10.0 and
support for half a dozen or so OCaml libraries.

Fedora releases happen about every 6 months.  Fedora 9 will be
released in a few months, shipping with OCaml 3.10.1[1] and the
following packages:

ocaml			base OCaml, ocamldoc, camlp4, etc.
ocaml-SDL               SDL
ocaml-calendar          Calendar (based on version 2.0)
ocaml-camlimages        CAMLimages
ocaml-cryptokit         Cryptokit
ocaml-csv               CSV support
ocaml-curl              ocurl
ocaml-curses            Curses support
ocaml-dbus              D-Bus (freedesktop.org)
ocaml-expat             Expat (XML)
ocaml-extlib            Extlib
ocaml-fileutils         Fileutils
ocaml-findlib           Findlib
ocaml-lablgl            OpenGL
ocaml-lablgtk           GTK2+
ocaml-libvirt           Libvirt (virtualization)
ocaml-ocamlnet          OCamlNet
ocaml-pcre              Perl-compatible regular expressions
ocaml-ssl               SSL
ocaml-ulex              Ulex
ocaml-xml-light         XML parsing
freetennis              Game
emacs-common-tuareg     tuareg-mode for emacs and xemacs

The following packages are also waiting to be accepted into Fedora 9,
so either they'll be in the basic version or will be available as
external packages and be pushed to Fedora 10:

cduce                   waiting for upstream release(?)
felix                   waiting for upstream release
mldonkey
ocaml-ast-analyze       being rewritten(?)
ocaml-cairo
ocaml-camlidl
ocaml-camlp5
ocaml-camomile          some license issues to resolve first
ocaml-cil
ocaml-gsl
ocaml-lacaml
ocaml-mysql
ocamldsort
ocamljava               experimental, needs a user/champion before going in
ocaml-odbc              experimental, only partially builds
ocaml-perl4caml
ocaml-pgocaml
ocaml-postgresql
ocaml-pxp
ocaml-sexplib
ocaml-sqlite
ocaml-type-conv
ocaml-xmlrpc-light
ocaml-zip

You can try out early versions of Fedora 9 right now:
http://fedoraproject.org/wiki/Releases/Rawhide

As for Red Hat Enterprise Linux (RHEL 5) we currently support OCaml
3.09.3 and a subset of the first list of packages above.  As ever,
people interested in long-term (7 years!) stable commercial support
should contact me with their requirements.

Rich.

[1] Perhaps 3.10.2 if released in time and there are no major
incompatibilities with libraries.

-- 
Richard Jones
Red Hat