Version française
Home     About     Download     Resources     Contact us    
Browse thread
Porting camlp4 stuff from 3.09 to 3.10: need help
[ Home ] [ Index: by date | by threads ]
[ Search: ]

[ Message by date: previous | next ] [ Message in thread: previous | next ] [ Thread: previous | next ]
Date: -- (:)
From: Richard Jones <rich@a...>
Subject: Re: [Caml-list] Porting camlp4 stuff from 3.09 to 3.10: need help
On Wed, Apr 09, 2008 at 11:46:52AM +0200, Loup Vaillant wrote:
> I am currently porting code which uses camlp4 from 3.09 to 3.10, and I
> am quite stuck.
> 
> I would like to know if there is a document which describes the
> compatibility breaking differences between the two versions. (The wiki
> doesn't seem to have it yet).
> It would also help me to know of the predefined quotations, (<:expr<
> >>, <:str_item< >>, and such) and what they allow.

I found the camlp4 wiki to be somewhat useful, and Martin Jambon /
Nicolas Pouillard's example of the differences between a 3.09 and a
3.10 extension to be a little useful too:

  http://brion.inria.fr/gallium/index.php/Camlp4
  http://martin.jambon.free.fr/examples/pa_json_static_3100beta.html

AFAIK the list of predefined quotations is the same as for 3.09, but
maybe this page will help:

  http://brion.inria.fr/gallium/index.php/Abstract_Syntax_Tree

> The mentioned line 78 is:
> 
>   <:str_item< declare end >>
> 
> It looks like the "declare end" construct is not allowed any more. Is
> there any equivalent in 3.10, and is there a specific bit of
> documentation about this?

Use the ordinary syntax instead?

Rich.

-- 
Richard Jones
Red Hat